The Crafty Miners | Minecraft Servers
THE CRAFTY MINERS

Description of  SaltyCraft

This is a brand new survival server.
Looking for staff, plugin managers and staff.
If you're interested in joining our team please direct message me on discord:
SaltyNick#9491

<br />
<b>Warning</b>:  Undefined variable $server_id in <b>/var/www/html/wp-content/plugins/oxygen/component-framework/components/classes/code-block.class.php(133) : eval()'d code</b> on line <b>21</b><br />
SaltyCraft Banner | The Crafty Miners | Minecraft Server List 2022

Overview

Players Online:
2/20
Last Seen: 7 days ago
Rating:
(No ratings Yet)
Votes This Month:
0
(Total: 0 )
Version:
1.16-1.19
Location:
United States (US)
United States (US) Flag
Uptime:
100%

Social Details

Gamemodes

FAQ of  SaltyCraft

How can I join the SaltyCraft Minecraft Server?

To join the SaltyCraft Minecraft server on Java Edition:

  1. Copy the Java IP Address above, by either clicking the "Copy IP" button above, or manually selecting the text and pressing "Ctrl + C".
  2. Open the Minecraft Launcher and make sure you have "Minecraft: Java Edition" selected.
  3. Click "Play" and your game should launch and begin loading.
  4. Once the homescreen appears, click on the "Multiplayer" button.
  5. From here, press the button that says "Direct Connect".
  6. In the "Server Address" box, press "Ctrl + V" to paste the IP in.
  7. Finally, press "Join Server" to connect to the Minecraft server and start playing!

Does SaltyCraft use Votifier?

Yes, the SaltyCraft Minecraft Server supports Votifier, meaning you'll be able to get rewards for coming back and voting everyday!

Make sure to come back every 24 hours to vote again! It will greatly help the server out!

Where is the SaltyCraft Server located?

The SaltyCraft Minecraft Server is located in United States (US).
To get the best connection speed, choose a server that is located close to you.

What versions does SaltyCraft support?

SaltyCraft supports the following version/s 1.16-1.19
You will be able to join SaltyCraft on any of the versions above, other Minecraft versions are not supported.